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Compatibility
This document is intended for use with version 1.1.3 of the SPRINT™ Freeform Surface application.

The application has been developed and tested against Productivity+™ version 3.1 but may also work 
with later versions.

Caution – Software safety
The software you have purchased is used to control the movements of a machine tool. It has been 
designed to cause the machine to operate in a specified manner under operator control, and has been 
configured for a particular combination of machine tool hardware and controller. 

Renishaw has no control over the exact program configuration of the controller with which the software 
is to be used, nor over the mechanical layout of the machine. Therefore, it is the responsibility of the 
person putting the software into operation to:

•	 ensure that all machine safety guards are in position and are correctly working before 
commencement of operation;

•	 ensure that any manual overrides are disabled before commencement of operation;

•	 verify that the program steps invoked by this software are compatible with the controller for which 
they are intended;

•	 ensure that any moves which the machine will be instructed to make under program control would 
not cause the machine to inflict damage upon itself or upon any person in the vicinity;

•	 be thoroughly familiar with the machine tool and its controller, understand the operation of work 
co-ordinate systems, tool offsets, program communication (uploading and downloading) and the 
location of all emergency stop switches.

IMPORTANT: This software makes use of controller variables in its operation. During its execution, 
adjustment of these variables, including those listed within this document, or of tool offsets and work 
offsets, may lead to malfunction.

Designations
Throughout this document, the following designations are used:

Screen names, fields names, dialogs, selectable menu options and program statement are 
referenced in oblique font. For example, Custom Macro: FreeformSurface; OutputFormat property.
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Before you begin
This document contains detailed information about how to use the probing software for programming, 
operating and controlling your machine tools. 

Split into four chapters and four appendices, this document is structured to provide the information that 
you require to use the probing software effectively.

•	 Chapter 1 provides a general introduction to the SPRINT Freeform Surface Toolkit.

•	 Chapter 2 describes how to create a basic Freeform Surface program.

•	 Chapter 3 introduces further programming techniques.

•	 Chapter 4 provides an overview of advanced tools available for use with the Freeform Surface 
Toolkit.

Measurement values
All examples and screenshots given within this document use metric measurement units. Where 
appropriate, equivalent imperial values are shown in brackets.

Measurement units used by the application are dependent on the selected post processor (.RenMF) 
file, and must match those shown in the Unit Mode toolbar of Active Editor Pro during program 
creation.

Folder locations
All folder locations used in this document are examples only. During installation, suitable folder 
locations will have been determined based on the individual device configuration.

NOTE: This document assumes that both the Productivity+™ CNC plug-in and the SPRINT Freeform 
Surface: On‑machine application are installed to an external data processor, connected to and 
communicating with, the CNC machine tool control.

Renishaw customer services – calling a Renishaw subsidiary office
If you have a question about the software, first consult the documentation and other information 
included with your product.

If you cannot find a solution, you can receive information on how to obtain customer support by 
contacting the Renishaw subsidiary company that serves your country.

When you call, it will help the Renishaw support staff if you have the appropriate product 
documentation at hand. Please be prepared to give the following information (as applicable):

•	 The version of the software you are using

•	 The make and model of your CNC machine tool control

•	 The exact wording of any messages that appear on your screen

•	 A description of what happened and what you were doing when the problem occurred

•	 A description of how you tried to solve the problem
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Chapter 1 – General information
This chapter provides a basic introduction to the SPRINT™: Freeform Surface Toolkit.

Overview
The SPRINT Freeform Surface Toolkit is a combination of software packages that support the 
scanning of component free-form surfaces. Scanning takes place on a CNC machine tool installed, or 
operating in conjunction with, the Productivity+™ CNC plug-in system. 

The software is designed to support the programming of non-prismatic scanning toolpaths through 
Productivity+ Active Editor Pro. Offering user-defined reporting in the form of CAD surfaces or sampled 
points, the application removes the need for complex processing of unfiltered scan data. 

Software packages
The SPRINT Freeform Surface Toolkit consists of three elements:

•	 SPRINT Freeform Surface: On-machine (Renishaw part no. A-5750-2200) – usually installed 
onto an external data processor which is connected to the CNC machine tool. This component of 
the Freeform Surface Toolkit deals with data processing and presentation of results to file or NC 
variables.

•	 SPRINT Freeform Surface: CNC plug-in Configuration – an installer element which is only 
required where SPRINT Freeform Surface: On-machine and the CNC plug-in are installed onto 
separate devices. In such instances, this Configuration element (provided as part of the Freeform 
Surface On-machine software) must be installed on the device hosting the CNC plug-in.

•	 SPRINT Freeform Surface: Editor (Renishaw part no. A-5750-2210) – an extension to 
Productivity+™ Active Editor Pro that provides the functionality to program free-form surfaces.

Surface patches
The areas of component surface to be scanned are identified as ‘surface patches’ and are defined by 
selecting a series of curves on the surface of the solid (CAD) model of the part. 

These curves are imported into Active Editor Pro and subsequently selected using the Freeform 
Surface tool. 

For more information including the number of curves required for various surface types, see “Importing 
wire geometry” and “ Create a Freeform Surface patch” in Chapter 2 “Basic programming”.

Also see Appendix A, “Required characteristics of selected curves”.
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Results and data presentation
The Freeform Surface Toolkit combines a ‘nominal surface’ for each surface patch with the data 
obtained from corresponding scans to generate a unique ‘solution surface’ for the individual scanned 
surface.

{

Nominal surface

Solution surface

Scan 
data

Solution surface data is saved to disk – which can subsequently be accessed for downstream 
processing – or sampled to access measurement data from the individual part such as:

•	 Surface positions

•	 Surface normal vectors

•	 Material condition

Any of the sampling data can also be written to NC variables.

NOTE: The solution surface represents the physical part – or a ‘virtual’ surface that is offset from 
it (see “Surface offsetting”). Data can be sampled from anywhere on the model, and there are no 
restrictions to the number of samples, however, the best accuracy is achieved when the samples are 
taken close to the scan curves.

Surface offsetting
Solution surfaces can be offset from the original component solid model. (An offset of zero will produce 
measurement data that is on the physical surface of the component.) 

Consider the following when determining the offset to be used.

•	 Downstream processing

Some processes may expect data that is offset from the physical part, for example, where 
tip‑centre data is required. In such instances, use an offset equal to the stylus tip (ball) radius.

•	 High curvature 

For high curvature, especially at higher scanning feedrates, it may be necessary to use an offset 
value approximately equal to the radius of the probe tip used for scanning.
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Requirements and prerequisites
The following elements are necessary in order to generate and execute SPRINT Freeform Surface 
programs.

•	 SPRINT Freeform Surface: Editor (Renishaw part no. A-5750-2210)

•	 Productivity+™ Active Editor Pro (Renishaw part no. A-4007-1400)

•	 Productivity+™ Active Editor Pro: SPRINT™ option (Renishaw part no. A-5226-2010)

•	 Post processor (.RenMF) file, correctly configured for the CNC machine tool on which the 
Freeform Surface Toolkit program(s) will be executed

•	 Probe database (.RenPD) containing the OSP60 probe configuration and tool change ID

•	 A CAD model of the component (for visualisation and collision detection purposes), associated 
fixturing, and wire geometry of the scan curves

CAUTIONS: 
Generated program files produced by the application are only compatible with the specific CNC 
machine tool make, model and controller type for which the post processor (.RenMF) file has been 
configured. Use of these programs on any other CNC machine tool make, model or controller type may 
result in damage to the machine tool, any loaded tools or workpiece inspection probes. 

As each post processor (.RenMF) file is calibrated to an individual CNC machine tool, it should not be 
assumed that program files will run successfully on any other machine tools, even those of the same 
make, model and controller type. 
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The importance of probe calibration
Calibration of the OSP60 is required to enable the accurate calculation of workpiece surface data and 
to facilitate correct tool path construction. This ensures that the probe tip is obtaining measurement 
data from the correct surface of the part. Once calibrated, probing software can be used to 
compensate for any difference between the position that the stylus touches and the position that is 
reported to the machine.

During normal use, the difference between the touch position and the reported position does not 
change, but it is important that the probe is calibrated in the following circumstances:

•	 when a probe system is to be used for the first time;

•	 when a new stylus is fitted to the probe;

•	 when a new shank is fitted to the probe;

•	 when on-centre adjustment has been carried out;

•	 when it is suspected that the stylus has become distorted or a probe crash has occurred;

•	 at regular intervals to compensate for mechanical changes to your machine tool;

•	 whenever the OSP60 is moved between machines;

•	 when very tight tolerances need to be achieved;

•	 when there is a need to take into account temperature changes in the machine environment;

•	 if repeatability of relocation of the probe shank is poor. In this case, the probe may need to be 
recalibrated each time it is selected;

•	 when the ‘hard overtravel’ threshold is reached (probe status LEDs show red and green).

It is good practice to set the tip of the stylus on-centre, because this reduces the effect of any variation 
in spindle and tool orientation. A small amount of run-out is acceptable and can be compensated for as 
part of the normal calibration process.

The probe is calibrated on the machine using a sphere of known size. Typically a sphere of Ø25 mm 
(or Ø1 inch) is used, but other sizes can also be used. The calibration routine comprises three stages:

•	 establishing the probe datum;

•	 determining the location of the calibration sphere and stylus ball radius;

•	 scanning the calibration sphere.

OSP60 probe tool length must also be accurately set using a tool of known length or a tool setter.

Calibration is performed through the Productivity+™ CNC plug-in software application. 

For information on mounting an OSP60 probe, stylus on-centre adjustment and probe calibration, see 
installation guide OSP60 SPRINT™ optical scanning probe (Renishaw part no. H-5465-8504).

Information on the calibration process is also available via the help pages of the CNC plug-in. With the 
CNC plug-in active on the CNC machine tool, select CNC plug-in Help > Common tasks > Calibrating 
a probe.
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Chapter 2 – Basic programming

Overview
Perform the following steps in order to create a Freeform Surface program that can be executed on a 
CNC machine tool.

1.	 Import the wire geometry into Productivity+ Active Editor Pro. 

Additionally, a solid model of the component – and any fixturing that may limit access – can be 
imported to take advantage of the collision detection functionality within Active Editor Pro.

2.	 Create Freeform Surface patches using capability within Active Editor Pro.

Using the Select Geometry menu item (SPRINT Toolkits > Freeform Surface > Select 
Geometry ), select wire geometry representing each patch to be scanned. This creates a group of 
Productivity+ statements that define each Freeform Surface patch.

3.	 Configure program settings.

Edit properties in the ProgramSettings and GlobalFFSSettings custom macros.

4.	 Configure the Freeform Surface patches.

Edit properties of each Freeform Surface Path to control various aspects of the measurement 
such as WCS selection; lead-on distance; lead-off distance; and surface resolution.

5.	 Visualise the toolpath in Productivity+ Active Editor Pro.

Check for collisions, review ordering, scan directions and retract moves for optimisation.

6.	 Configure output.

Output the solution surface to file, or write sampled points from the surface to file or NC variables.

7.	 Post process the program.

The Freeform Surface Editor requires a custom post processing operation accessible from the 
SPRINT Toolkits menu. Do not use the standard Active Editor Pro post processing icon or menu 
option to generate Freeform Surface programs.

These steps are covered in more detail below.

TIP: Content-specific help is displayed by hovering the mouse pointer over individual statement 
properties (within the Property Viewer window) or within dialog boxes.

Having performed the above steps the following will have been created:

•	 An NC program, which can be uploaded to the CNC machine tool control;

•	 A folder structure containing supporting files that should be copied to the external data processor 
hosting the SPRINT Freeform Surface: On-machine application.

NOTE: User guide SPRINT Freeform Surface: On-machine (Renishaw part no. H-5750-8531) 
describes the deployment of supporting files.
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Importing wire geometry
Wire geometry for the patches to be scanned should be generated using a suitable CAD tool. 

Instructions for this will depend on the particular application being used and are beyond the scope 
of this document, however it is important that the wire geometry has the characteristics described in 
Appendix A “Required characteristics of selected curves”.

Once you have created your wire geometry, import the model into Active Editor Pro. For further 
information, see Appendix B, “Importing solid model and wire geometry”.

NOTE: The Freeform Surface Toolkit only requires wire geometry for the creation of measurement 
programs, however the import of other elements – such as the component and fixturing – is 
recommended in order to utilise the collision detection functionality within Active Editor Pro.

Create a Freeform Surface patch
Click SPRINT Toolkits > Freeform Surface > Select Geometry and select the wire geometry for the 
patch to be scanned. 

Press Enter when complete.

TIPS: 

Use Ctrl + click or left-click and drag to select multiple curves.

Use Ctrl + Shift and left-click to automatically select multiple connected sections of a single curve.
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Patches can be created from two or more selected curves. The number of curves selected has an 
important influence on behaviour of the application as described in the table below.

Curves 
selected

Curves 
scanned

Surface 
type

Description

1 - - Single curve selection is unsupported.
2 2 Ruled/ 

ribbon
Both selected curves will be scanned.  
The bounds of the nominal surface are defined by the Edge 
Margin setting (Tools > Options > FreeformSurfaceSettings > 
SurfaceDefinition).

3 1 Ruled/ 
ribbon

Only the middle curve is scanned.  
The outer curves define the bounds of the nominal surface.

4 2 Ruled/ 
ribbon

The middle two selected curves are scanned. The outer curves 
define the bounds of the nominal surface.

n (> 4) n − 2 Doubly 
curved

All but the two outer curves are scanned.  
The outer curves define the bounds of the nominal surface.

NOTE: The optimum number of scans depends on the specific requirements of the application. 
Appendix C “The implications of the number of curves used to define a surface patch” describes the 
issues to be considered and the behaviour of the tool in the various scenarios listed above.
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Configuring overall program settings
Settings that apply to the Freeform Surface program as a whole can be configured in the Custom 
Macro: ProgramSettings and Custom Macro: GlobalFFSSettings statements.

NOTE: These custom macro statements are automatically generated when the first patch is created.

As a minimum, the ProcessStatusNCVariable property (in Custom Macro: ProgramSettings ) should be 
set to a free NC variable. When the Freeform Surface program is run on a machine tool, this variable 
will be set to 0 (zero) to indicate success, or a non-zero value to indicate failure.

Settings can also be configured in the FreeformSurfaceSettings area of the Active Editor Pro Options 
menu (Tools > Options > FreeformSurfaceSettings), allowing default settings provided by the 
application to be overwritten for individual patches.
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Custom Macro: FreeformSurface property configuration
The top-level custom macro for each patch contains properties that can be used to control various 
behaviours, such as:

•	 Initial fitting of the nominal surface to the scan data (recommended for moderate curvature, 
especially when rastering). (See Appendix D “Configuring the scanning toolpath” for information 
on rastering.);

•	 Resolution of the solution surface (lower resolution can be used to filter out unwanted surface 
noise);

•	 Saving a solid model of the solution surface to disk.

NOTE: For detailed information refer to individual property help text.

Child statement property configuration
Each Freeform Surface patch within the measurement program is represented by a single, top-level 
Custom Macro: Freeform Surface statement with a number of child statements. 

Child statements for a patch consist of:

•	 A number of Surface Definition statements.

These should not be modified and can be ignored.

•	 An Inspection Cycle containing a single Scanned surface statement.

The properties of these statements can be modified to configure the work co-ordinate (WCS), 
probe and various characteristics of the scanning toolpath. 

In particular, the selected wire geometry may extend beyond the area of interest. Use the Start 
distance and End distance properties of the Scanned surface child statement to adjust the length 
of the measured patch at either end.

Start distance End distance

Other properties can also be configured. Careful consideration is required as described in 
Appendix D “Configuring the scanning toolpath”.
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NOTE: It may be necessary to use the Co-ordinate System Manager to align the Current CS (as 
defined in the Inspection Cycle child statement) for access. In this version of the Toolkit, all data 
is reported in the measurement frame defined by the Current CS. It is the user’s responsibility to 
transform the output data into a different frame as required.

NOTE: Feedrate Multiplier 
The Feedrate Multiplier property in the Scanned surface statement controls the scanning speed 
of the probe, with a value of 100% corresponding to the _SCAN_FULL_FEED defined in the 
.RenMF file.

Accuracy and robustness can deteriorate with increased feedrate. It is therefore recommended 
that accuracy is benchmarked using a feedrate multiplier of 5%. The multiplier used for a 
particular application can be selected through experimentation to satisfy individual cycle time and 
accuracy requirements.
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Visualise the toolpath
Once a Freeform Surface patch has been created, Active Editor Pro offers a preview of the toolpath via 
the Design tab.

The different regions of the toolpath can be identified by their colour.

Toolpath colour Toolpath region

Magenta Arc on/arc off

Green Lead on/lead off

Yellow Guard distance

Red Scanning toolpath

NOTE: The toolpath preview shows the stylus (ball) tip bottom position, which, depending on probing 
angle is equivalent to the tip radius distance below the target contact point (and offset by the tip radius 
distance from the surface).

TIP: Use the Visualisation tab in Active Editor Pro to view a simulation of the scanning toolpath.
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Configure output
Data from the Freeform Surface patch can be reported in a number of ways.

•	 The solution surface can be written to file in NURBS or IGES format.

Use the OutputFormat property of the relevant Custom Macro: FreeformSurface statement to 
control output of the solution surface to file.

•	 User-defined points can be sampled from the solution surface and then written to file or NC 
variables.

Select the required Custom Macro: FreeformSurface statement – or one of its child statements 
– and use the Add Surface Sampling menu item (SPRINT Toolkits > Freeform Surface > Add 
Surface Sampling) to add a Custom Macro: SurfaceSampling statement. 

The properties of this SurfaceSampling custom macro can then be used to specify the points that 
should be sampled and to configure the output format.

The points at which the solution surface should be sampled can be automatically generated 
by the Toolkit or specified by the user (via a comma-separated file containing three columns 
corresponding to the XYZ positions of the sampling points on the nominal surface). 

The Toolkit can output the sampled points to a file – in a user-specified format string – or to NC 
variables. For further information refer to property help text.

NOTE: For many applications, the deviation reported by the SurfaceSampling custom macro 
is equivalent to the material condition. However, if the FitType property of the Custom Macro: 
FreeformSurface statement is set to a value other than None, this is not the case. Use of an initial 
constrained fit is an advanced option for higher curvature surfaces. Renishaw customer services 
should be contacted if further information about this option is required.
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Custom Post Processing
In order for the measurement program created in Active Editor Pro to run on the machine, an NC 
program must be generated.

This is achieved using the Post Process menu item (SPRINT Toolkits > Freeform Surface > Post 
Process).

Settings in the Freeform Surface Post Process dialog box must be configured, ensuring that the 
specified Machine Definition File (.RenMF) matches the .RenMF file used on the CNC machine tool.

Any warnings or errors in the program will appear during posting. 

If posting has been successful, the following files will be produced in the specified Post Output Folder 
location:

•	 The posted NC program

An NC program file, named according to the NC Output File field in the posting dialog. This file 
should be uploaded onto the control and run as normal.

•	 Support files folder

A subfolder, named according to the Part Name field in the posting dialog. This subfolder contains 
files necessary for the run-time process and must be copied into the External PC Working 
Folder (C:\SPRINT_REMOTE or equivalent) on the external data processor hosting the Freeform 
Surface On-machine application before executing the posted program.
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Chapter 3 – Further programming

Archiving
The SPRINT Freeform Surface Toolkit provides an optional archiving mechanism. 

When enabled, archiving saves all data from each run to a time-stamped folder. 

As well as providing a historical record for later analysis, this provides important functionality for the  
investigation and analysis of any process failures.

NOTE: Output data is always cleared from the part folder structure at the end of each run. The 
CustomActionScript mechanism can be used to copy output data to any user-defined location prior to 
the process clearing the part folder structure. Use of this mechanism is recommended to ensure output 
data is available for downstream processes rather than relying on archiving.

Archiving is controlled by the Archiving property of the Custom Macro: ProgramSettings statement. 
This can be set to Always Archive, Never Archive, Archive On Failure or NC Variable Controlled. 

For more information refer to the Archiving property help.

NOTE: Archives can be large and over time may fill up the hard drive. It is recommended that the 
Archiving property is set to Archive on Failure for long-term use. Never Archive should only be used 
to avoid excessive archiving where regular processing failures are expected. For example, out of 
tolerance parts causing over/under deflection.
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Custom Actions
Custom Action Scripts provide a mechanism to manipulate the file system on the external data 
processor at key points in the process. Any executable or script can be used, as long as it can be 
launched from a command line on the external data processor.

Typical actions may include loading nominal data from a network resource at the start of the process 
(using the UsePreCustomActionScript property), or copying output data to an alternative location at 
the end of the process (using the UsePostCustomActionScript property).

NOTE: All output data is archived to a time-stamped folder that is not easily accessible. The 
UsePostCustomActionScript property allows data in the output folder to be accessed before it is 
archived.

Files written or moved into the working folder by the UsePreCustomActionScript property are protected 
from the usual clean-up process that occurs at the start of each process.

In each case, the return value of the script or executable is written to the NC variable specified in 
the Pre / PostCustomActionStatusNCVar properties. These NC variables can then be checked in the 
calling G-code program and dealt with as necessary.

The UsePreCustomActionScript and UsePostCustomActionScript properties can be turned on and off 
independently.

When turned on, the corresponding CustomActionScriptPath property should define the full 
path to the script or executable as seen from the external data processor. The corresponding 
CustomActionStatusNCVar properties should be configured to define free NC variables.
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Chapter 4 – Advanced tools

Reselecting geometry
Sometimes there is a requirement to update the geometry associated with an existing Freeform 
Surface patch; for example, where solid model geometry or a co-ordinate system has been changed 
after program creation.

To reselect geometry, select the relevant Custom Macro: FreeformSurface statement (or one of its child 
statements) within the measurement program, click SPRINT Toolkits > Freeform Surface > Modify > 
Re-select Geometry. 

This will modify the data stored in the patch without changing the value of properties set in the Custom 
Macro: FreeformSurface, Inspection Cycle and Scanned surface statements.

Inverting surface normals
The Freeform Surface Toolkit makes the assumption that when wire geometry is selected, the user 
is viewing the surface from the side to be scanned: the toolpath is then generated on that side of the 
surface. 

If this assumption is incorrect, the generated toolpath will be on the wrong side of the component, 
however this can be corrected by using the Invert menu item.

Select the relevant Custom Macro: FreeformSurface statement (or one of its child statements) within 
the measurement program, click SPRINT Toolkits > Freeform Surface > Modify > Invert.
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Running in ‘Detached Mode’
Surface processing is an intensive operation. Where programs involve the scanning of several surface 
patches, enabling asynchronous processing can provide cycle time reductions.

Select the required Custom Macro: FreeformSurface statement (or one of its child statements) within 
the measurement program, click SPRINT Toolkits > Freeform Surface > Modify > Detached Mode. 

This will add a Custom Macro: WaitForFFS statement to the program.

The Custom Macro: WaitForFFS statement must be positioned before the next statement that 
relies on the results of the relevant Custom Macro: FreeformSurface statement; for example, the 
corresponding Custom Macro: SurfaceSampling statement.

NOTES: 
Use this feature with care as positioning the Custom Macro: WaitForFFS statement after a dependent 
statement will cause the process to fail rarely and unpredictably.

In order to change a Custom Macro: FreeformSurface statement back to non-detached mode, simply 
delete the corresponding Custom Macro: WaitForFFS statement.
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Appendix A – Required characteristics of selected curves
SPRINT Freeform Surface is designed to measure patches of a surface, provided that the patches 
have the following characteristics.

•	 The patch is defined by a number of roughly parallel curves of approximately equal length.

(a)

/

(b)

/

(c)

,
(a) Not acceptable: selected curves are not parallel.

(b) Not acceptable: selected curves are not of equal length.

(c) Acceptable: selected curves are approximately parallel and of approximately equal length.

•	 The patch is open – the two ends of a single patch do not overlap. 

,

(b)(a)

/
(a) Not acceptable: selected curves are closed.

(b) Acceptable: selected curves are open.

•	 It is recommended that scanning is not performed along, or very close (within approximately 
1 mm) to, areas of high curvature.

,
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•	 The parallel curves defining a patch should be relatively straight in the surface space.

(a)

/

(b)

/

(c)

,
(a) Not acceptable: curves are not straight in surface space.

(b) Not acceptable: curves are not straight in surface space.

(c) Acceptable: curves are relatively straight in surface space.

•	 Natural variation in physical parts lead to uncertainty in the contact position of the stylus against 
the surface during scanning.  

For each scan, it is important that contact occurs within a single region defined by the 
neighbouring curves. Where the distance between neighbouring curves is small, the contact path 
may stray outside this region, causing the analysis to fail. A minimum spacing of 0.5 mm between 
curves is recommended.

Limitations and validation
It is extremely difficult to guarantee successful execution and accurate results via automatic validation 
of the defining curves during program creation. To do so reliably would mean rejecting a large number 
of feasible cases. 

For this reason, validation is limited; instead the user should exercise judgement based on the 
guidelines above. It is important to assess the accuracy of the results, especially where the capabilities 
of the tool are being stretched in relation to the guidelines described above.
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Appendix B – Importing solid model and wire geometry
In Productivity+ Active Editor Pro click the Import Solid Model icon (or File > Import Solid Model ).

Navigate to and select the required solid model file and click Open to import the model into the Active 
Editor Pro session.

Repeat this procedure to select the file containing the wire geometry.

Ensure the Include wire geometry? check box is ticked before clicking Open.

TIP: Hold down the Ctrl key and left-click to select and import multiple files in a single operation.
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Appendix C – Implications of the number of curves defining 
a surface patch
When using the SPRINT Freeform Surface Toolkit, the number of selected curves governs how many 
curves are scanned and the type of information that can be obtained about the part. 

The number of curves that should be selected for a given application depends on the characteristics of 
the part.

Vertical, singly-curved surfaces
When scanning a vertical, singly-curved surface, a single scan along 
the direction of curvature of the surface is sufficient. (More curves can 
be scanned where information about the form of the surface at different 
heights is required.)

To scan a single curve, three curves must be selected: the central curve 
is scanned, the other two curves define the extents of the nominal 
surface. The nominal and solution surfaces are ruled surfaces.

NOTE: A ruled, or ‘ribbon’, surface is completely defined by its top and 
bottom edges. It can model curvature in the direction of the selected 
curves – and twisting – but it cannot model curvature perpendicular to the 
direction of the selected curves.

Sloped, singly-curved surfaces
When scanning a sloped surface, it is recommended that at least two 
curves are scanned in order to distinguish surface gradient from material 
condition.

To scan two curves, either two or four curves should be selected. If two 
curves are selected, both of these curves will be scanned and the extents 
of the nominal surface will be defined by the Edge Margin, specified 
in the Options menu (Tools > Options > FreeformSurfaceSettings > 
SurfaceDefinition > Edge Margin (2 Curve Selection)).

If four curves are selected, the central two curves are scanned and the 
outer two curves define the extents of the nominal surface. In both cases, 
the nominal and solution surfaces are ruled surfaces (see “NOTE” above).
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Doubly-curved surfaces
In order to model a surface with double curvature, at least three curves 
must be scanned, which requires the selection of five or more curves. 

The outer two curves define the extents of the nominal surface and the 
remaining curves are scanned. Increasing the number of curves will 
increase the ability of the Freeform Surface Toolkit to model complex 
curvature in the direction perpendicular to the selected curves.

NOTE: Contact point uncertainty is an issue for all probing systems, but 
especially SPRINT due to the freedom of the probe to deflect in three 
dimensions. The Freeform Surface Toolkit uses the large amount of 
data from SPRINT to build an actual model of the surface in the area of 
interest. Provided the number of scan curves is sufficient to represent the 
shape of the underlying surface, the resultant model can be sampled at 
known nominal positions to remove uncertainty from the measurements.
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Appendix D – Configuring the scanning toolpath
Active Editor Pro allows the properties within the Scanned surface  
statement of each Freeform Surface patch to be configured.

An explanation of the function of some of these properties is provided 
below.

Please also refer to individual property help.

Number of rasters
This property defines the number of times each curve is scanned. 

When set to a value greater than one, each curve will be scanned 
multiple times, and the probe will move slightly closer to the surface 
with each raster.

Rastering is useful where there is significant uncertainty as to the 
form and/or position of the part as it increases the likelihood of 
obtaining valid data for all parts of a scan. 

The Toolkit selects and combines the best data from each raster to 
generate a single set of scan data for use in down-stream processing.

Maximum material and Minimum material

NOTE: These properties are only visible when the Number of rasters property is set to a value greater 
than one (1).

These properties specify the material condition range to be covered during rastering.

As material condition range increases it may be necessary to increase the number of rasters. Take 
note of any warnings displayed during post processing to ensure that the number of rasters is 
sufficient to cover the specified material condition range.

[  ] arc-on radius; [  ] arc-on angle; [  ] arc-off radius; [  ] arc-off angle
These properties define the path of the OSP60 SPRINT probe as it contacts and leaves the 
component surface. 

Modify these properties as required to avoid collisions where access is restricted.

Start distance and End distance
These properties define the length of the scanned region relative to the selected wire geometry.

Increasing these distances will shorten the scan. 

Probe in contact with part surface

Lead on Lead off

Start 
distance

End 
distance

Guard distance Guard distance

Selected geometry

Data used for surface fitting

Both Start distance and End distance properties should be set to a value greater than zero (0) as the 
Toolkit requires information about the shape of the nominal surface beyond the ends of the scanned 
region. 

It is recommended that the value for both properties is at least 1 (mm): a post-processing warning will 
be generated if either value is less than this.
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Lead-on distance and Lead-off distance
These properties define the distance that the probe is in contact with the surface beyond the ends of 
the scanned region, allowing data that may be affected by acceleration/deceleration or vibration to be 
ignored. 

NOTE: These distances alter the length of the scan, and so may affect access.

Guard distance
This property defines a distance at the start and end of the scanned region over which collected data 
is ignored for all rasters. This is particularly important when rastering, in order to ignore data affected 
by toolpath reversal where lead on/off does not help. 

NOTE: In contrast to the Lead-on distance and Lead-off distance properties, Guard distance does 
not change the length of the physical scan, but instead causes data at the ends of the scan to be 
discarded. When rastering, it is recommended that Guard distance should be at least 1 mm. When not 
rastering, it is recommended that the sum of Guard distance and Lead-on distance are at least 1 mm.

Feedrate Multiplier
This property controls the scanning speed of the probe, with a value of 100% corresponding to the 
_SCAN_FULL_FEED defined in the .RenMF file.

Accuracy and robustness can deteriorate with increased feedrate, so it is recommended that accuracy 
is benchmarked using a feedrate multiplier of 5%. The multiplier used for a particular application can 
be selected through experimentation to satisfy individual cycle time and accuracy requirements.
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